So with the recent release of Minecraft Forge for 1.8.9, and plenty of servers expressing interest in the new version, we are planning to soon retire support for Minecraft 1.8.0.

We will still publish builds for Minecraft 1.7.10, but our 1.8.x branch will switch to targeting 1.8.9 instead. This will allow us to do a few things:

  • Compatibility with Sponge API, who now have 1.8.9 builds of SpongeForge available (hopefully I can talk about this more in a later blog post)
  • Require Java 8 for servers (and maybe clients). This should not be an issue as Java 8 has been out for a while now.
  • Some more other things which we haven’t decided on yet.

We hope you will be able to understand why we’re doing this, and any questions can and will be answered on the relevant github issue.

10 comments on “Upcoming end of support for Minecraft 1.8.0

Leave a Reply

Your email address will not be published. Required fields are marked *